Opened 5 years ago

Last modified 4 years ago

#131 reopened enhancement

Add "Antigen Unit" (AgU) and "D Antigen Unit" (DAgu)

Reported by: lmckenzi Owned by:
Priority: minor Milestone:
Component: Keywords:
Cc: gschadow

Description (last modified by gschadow)

CDISC has the following codes:

C70500 "Antigen Unit per Milliliter" (AgU/mL) definition: A measure of an antigen potency defined as a number of antigen units per one milliliter of product.(NCI)

Google search count for "AgU/ML": 490

C70501 "D Antigen Unit" (DAgU) definition: A unit of potency of poliovirus vaccine used for poliomyelitis prevention. The unit is poliovirus type-specific.(NCI)

Google search count: Not relevant (Dagu is a popular term :>)

C70502 "D Antigen Unit per Milliliter" (DAgU/mL) definition: A unit of potency of poliovirus vaccine expressed as a number of D antigen units per one milliliter of vaccine formulation.(NCI)

Google search count: 171

Discussion: Not sure whether "DAgu" is reasonable or not. It may just be a qualifier on the type of vaccine. E.g. "[AgU] {Polio}" or something like that. However, AgU seems to be reasonable.

Change History (6)

comment:1 Changed 5 years ago by gschadow

  • Resolution set to worksforme
  • Status changed from new to closed

The question is, do we have an antigen unit or not? Haven't we added [AU] and [BAU] recently? I think we have. If we have, then [AU]/mL is already acceptable UCUM code and we do not need to do anything. I move to resolve this proposal as "worksforme". Please re-open if I am incorrect.

comment:2 Changed 5 years ago by gschadow

  • Milestone set to Revision 1.9
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Actually, the remaining issue, D-Antigen Unit, is a duplicate of #37. Needs to be flushed out now.

comment:3 Changed 5 years ago by gschadow

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:4 Changed 5 years ago by lmckenzi

  • Resolution duplicate deleted
  • Status changed from closed to reopened

In CDISC, "AU" and "BAU" exist as distinct units to "AgU". AU = Allergen unit. BAU = Bioequivalent Allergen Unit. On the other hand AgU is "Antigen Unit". I don't have the clinical/scientific background to explain how an "allergen unit" is distinct from an "antigen unit", but both terms exist in the literature (as seen from google search) and both are defined as distinct codes in CDISC's code list.

comment:5 Changed 4 years ago by gschadow

  • Description modified (diff)

Hi Lloyd, this is an attempt to get up to date and actually resolve a list of issue which have not been addressed for some time.,

We have d-Antigen Unit already, it is called [D'ag'U] and it is a unit against a standard of a specific antigen. The definition text of [D'ag'U] is actually wrong, it was "procedure defined amount of an antigen substance" but it should be more specific: from http://www.cancerterms.net/define-D+Antigen+Unit/ I get "A unit of potency of poliovirus vaccine used for poliomyelitis prevention. The unit is poliovirus type-specific." An authoritative reference about this standard is probably: http://whqlibdoc.who.int/bulletin/1967/Vol36/Vol36-No2/bulletin_1967_36(2)_209-218.pdf.

With AgU, the things are very different. I found a fairly decent definition in this reference: http://www.degruyter.com/dg/viewarticle.fullcontentlink:pdfeventlink/$002fj$002fpjct.2013.15.issue-3$002fpjct-2013-0037$002fpjct-2013-0037.pdf?t:ac=j$002fpjct.2013.15.issue-3$002fpjct-2013-0037$002fpjct-2013-0037.xml

There it says:

"1 AGU is the amount of enzyme which hydrolyzes one micromole of maltose per minute in specified conditions"

Notice how it is International Union of Biochemistry's enzyme units 1 U = 1 umol/min. As such, it would be most adequate to use the unit U.

But what does this "AG" stand for in "AGU"? In some references on the Internet, it relates to amylase, which fits the reference above. It is definitely not always for "antigen".

Let's search Google again:

  • +"AgU/mL" +"antigen unit"
    • yields 1,540 results
  • +"AgU/mL" +"amylase"
    • About 337,000 results

Because one can not say from your Google references that "AGU" actually means "Antigen Unit" we can not add it without having a scientific reference.

So, in conclusion,

  • we have [D'ag'U] resolved, including its text description fixed.
  • AgU is at best ambiguous and we need to get a real scientific paper reference.

comment:6 Changed 4 years ago by gschadow

  • Milestone Revision 1.9 deleted
Note: See TracTickets for help on using tickets.